Page 1 of 1

bq8030 only DSG flag

PostPosted: Tue Mar 14, 2017 5:03 pm
by boss87
Hi,
I replaced cells, reset the chip, everything works fine.
I discharged battery, and I cant charge it.

Fuse is ok, when I dischargnig battery witch current >300mA I can see the charge fet is turning on. But it is off when charger is connected.

What I am doing wrong ? Maybe there is some PF flag ?

Re: bq8030 only DSG flag

PostPosted: Wed Mar 22, 2017 8:24 pm
by boss87
Hi Guys,
any advices how to handle with it ?

flags FD and DSG are active, that is strange...

Re: bq8030 only DSG flag

PostPosted: Wed Mar 22, 2017 9:27 pm
by admin
<flags FD and DSG are active, that is strange.>
DSG flag always appear when battery is not charging.
Even if load is not connected.
Because there is always self discharge carrent is running.

When you reset BQ8030 PF flags are cleared.
If it appear again then it's a battery hardware problem or most likely cells imbalance is too high.
Also check if temperature is correct.

Re: bq8030 only DSG flag

PostPosted: Sat Apr 01, 2017 10:37 am
by boss87
Cells are balanced +-5mV, temperature reading is ok, ~25*C.
Cell Voltage is circa 4.0V, discharging them to 3.0V may help ?

Re: bq8030 only DSG flag

PostPosted: Sat Apr 01, 2017 10:59 pm
by admin
Discharge your battey with battery analyzer and show the result.

Re: bq8030 only DSG flag

PostPosted: Sun Apr 02, 2017 7:53 am
by boss87
But CHG fet and DSG fet are not open, i can do this by connecting to cells directly

Re: bq8030 only DSG flag

PostPosted: Sun Apr 02, 2017 8:02 am
by admin
You must do this by connecting to battery terminals.
If you made reset but FETs are not open then check if you need connect pin SYS_PRES to GND.